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Preface  
This Learner’s Book has been written in line with the revised ICT Syllabus. The knowledge 
and skills which have been incorporated are what is partly required to produce a learner who 
has the competences that are required in the 21st century.  
 
This has been done by providing a range of activities which will be conducted both within 
and outside the classroom setting. The learner is expected to be able to work as an 
individual, in pairs and groups according to the nature of the activities.  
 
The teacher as a facilitator will prepare what the learners are to learn and this Learner’s 
Book is one of the materials to be used to support the teaching and learning process. 
 
 
 
 
 
Associate Professor Betty Ezati 
Chairperson, NCDC Governing Council 
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Chapter 1 
Introduction to ICT 

 

 

 
 
 
 
 
 
 
 
 
 
Introduction  
In this chapter you will learn about the meaning of ICT and appreciate its various 
applications in daily life. Just imagine the world without ICT! How would communication, 
transfer of money, security, transport, learning among others in our lives be like? 

 
Meaning of ICT 
ICT stands for:  
I – Information,  
       C – Communication  
                T - Technology  
 
Hardly a day passes when ICT does not intrude into our lives. ICTs are used daily in one way 
or another; people are connected through telephone networks, the Internet and the World 
Wide Web. Refer to Figure 1.1. 

By the end of this chapter, you should be able to: 
a) explain what ICT is all about. 
b) identify common ICT tools and their uses in various fields. 
c) use various ICT tools. 
d) appreciate the Safety precautions for the different ICT tools. 

Key Words 
 ICT 
 hardware 
 software 
 peripherals 
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Figure 1.1: Common ICTs 

Imagine Mr. Kaboyo making a telephone call to his mother, Mukade Jalia, to send her New 
Year greetings. In this case, Mr. Kaboyo and his mother are communicating using technology 
(mobile telephone) and information is the New Year greetings.  
ICT can be compared with other systems. Let us compare ICT and a water system.  
 
NOTE: ICT is electronic while a water system is mechanical 
 
Imagine a water system comprising a water tank, water, taps, pipes and water moving 
through the pipes. This can be related to ICT as follows. 
 
Table 1.1: Comparison of a water system and an ICT system 
Water system component ICT 
Taps, water tank, pipes Technology 
Water Information 
Water flowing through pipes Communication 
 
Activity 1.1: Meaning of ICT 

1. In groups, look around your school or your community and identify at least 3 ICTs 
familiar to you. State the function of each of the ICTs identified in the table below. 
Table 1.2: ICT tools and their functions 

ICT Tool Function 
E.g. Camera Capturing photographs 
1.  
2.  
3.  
4.  

 
2. Select any two ICTs from Figure 1.1 and identify the information they handle, the 

nature of communication that takes place and the technology used. 
3. With the available ICT tool, practice using it and identify the I, C, and T in it. 

 

Common ICT Tools  
At the beginning of this chapter, you learnt about the meaning of ICT. When we talk about 
ICT tools, we are referring to devices or objects used in ICT. As people need and use 
hammers, hoes, conveyor belts and pangas to produce, process and manufacture food, they 
similarly use tools for data capture and processing, information storage and communication.  
Therefore, ICT tools are not one solid thing but rather a collection of several electronic tools.  
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Figures 1.2 – 1.5 show some examples of basic ICT tools we interact with in our day-to-day 
activities. 

 
Figure 1.2: Desktop computer set                                                             Figure 1.3: Television sets 

                                     

                                                Figure 1.4: Telephone handsets                                       Figure 1.5: Radio 

 
Activity 1.2: Common ICT tools  
In groups, identify the ICT tool provided by name and characteristic(s). Summarise your 
findings in Table 1.3. 
 
Table 1.3: ICT Tools and their characteristics 
Name of ICT tool/s  Characteristics  
Computer  Electronic tool 

 Has hardware and software 

 Can store information temporarily or 
permanently 

  
 
 

  
 
 
 

 
Activity 1.3: Identifying ICT tools with their specialized professional fields or areas 
Identify and state some ICT tools and what they can be used for in specialized fields such as 
communication, manufacturing, teaching and learning, health and medicine, security, 
climate and weather, management. 
 
Note: A computer is a major component of ICT. 
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Use of ICTs ii society /Application of ICT 
At the beginning of this chapter, you learnt that 
ICTs are used to collect and share information. In 
all situations, the ICT devices are used by people 
or programmed by people to simplify work.   
In our society today, use of ICT is on the increase 
in all areas. ICTs are used to collect and 
communicate information in our homes, schools, 
hospitals, banking halls and many other places. 
ICTs are also used in the entertainment industry, 
security, agriculture and transport.  
In the security sector, ICTs are used to monitor sensitive areas like banking halls and 
airports, screening bags for unwanted materials and objects, and many others. However, 
good ICTs may, in some cases, pose challenges. 
 
Activity 1.4:  Application of ICTs 

a) In groups, identify the ICT devices used in each of the application areas shown in 
Table 1.4 and what they are used for. Please note that each of the application areas 
can have as many ICT devices as possible.  
 

Table 1.4: Application of ICTs 
Application area Name of ICT Device What is it used for? 
Home Mobile phone Sharing information in form of SMS, 

pictures, emails, voice messages between 
users  

  
School   

  
Entertainment   

  
Security   

  
Hospitals   

  
Transport   

  
Agriculture   
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Figure 1.6: Electronic Point of Sales (EPOS) 

b) Give any advantages and disadvantages of using ICTs in our society. 

ICTs in business 
Most supermarkets, especially the big ones, have 
adopted the use of Electronic Point of Sales (EPOS) 
(Figure 1.6). If you have bought an item from a shop 
and it is scanned to determine the amount you need to 
pay, you have used an EPOS. An Electronic Point of 
Sales (EPOS) is self-contained, computerized 
equipment that performs all tasks of a store checkout 
counter. It allows payments by cash, bank or credit 
cards, verifies transactions and generates a sales 
receipt. It also coordinates inventory data. With this 

technology, the shop owners are able to know the 
items that are bought most, what is left in the stores 

and the items that are running out. 
 
Activity 1.5: Application of ICT in business 
a) In groups, identify the ICT devices used in any business in your area and what they are 

used for. 
b) Discuss and make a presentation on the different ways in which a mobile phone can be 

used as an ICT tool to support business activities.   
 

Handling and Maintaining ICT Tools 

Taking care of your ICT Tools is just as important as taking care of your books. The internal 
and external parts of the computer and other ICTs have to be cared for. Taking care of ICT 
tools is supposed to be done by all people who use them. However, as a learner you cannot 
do all care and safety activities. Activities that require one to open up these tools are left to 
people who have undergone specialized training on how to do it. As an ICT user, there are 
certain tasks you can perform to ensure your ICT tools are clean.  
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These include:  

 

 

 

 

 

 

a few: 

 

  

 

 
 
 
 
 
 
 
Some Computer laboratory safety and maintenance tools and their functions are 
summarized in the Table 1.5. 
 
Table 1.5: Maintenance tools and their functions 
Maintenance tool Function 
Dust blower  Can be used regularly to blow dust out of a computer. 
Air conditioner Regulates computer lab temperatures. 

 
Activity 1.6: Handling and maintaining ICT tools 

1. Other than a dust blower and an air conditioner identify any other ICT maintenance 
tools in the computer laboratory and state their functions. 

2. Identify a computer which needs cleaning and clean it up with the necessary tools. 

3. Make a report of the steps followed in 2 above and tools used in the cleaning process. 
 

ICT Safety Precautions  
As ICT users, it is very important to take precautions when using ICT tools to avoid getting 
health problems. We shall learn more about this in the chapter on Health and Safety. To 

 Keep dust away: Dust your computer to keep it free of dust and dirt. 

 Keep food away: Do not eat or drink while working on the computer. 

 Use clean and dry hands: Make sure your hands are clean before you type on the keyboard of 
click the mouse. 

 Treat with respect: If you are having problems with your computer, ask for help. Do not bang 
or hit the computer. 

 Keep the Computer off power during a storm: When a computer is connected to electricity 
during a heavy downpour, there is a possibility of lightning being conducted to your computer 
through the electrical connection. For this reason, it is best not to use your computer during a 
storm. 

 Stop virus attack: A computer virus is a program written by a person on purpose to harm other 
peoples’ computers. A computer virus is passed from one computer o another when you share 
and download files without the protection of antivirus software. For this reason, you should get 
permission before downloading files. 

 Handle with care: The way you handle your CDs will determine how long they will last. Always 
hold the CD correctly as shown in figure 1.7.  
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ensure that ICT tools are used with caution, manufacturers provide user manuals for all ICT 
equipment.  
 
 
Activity 1.7: ICT safety precautions 

1. In groups, discuss “rules that govern the use of the computer laboratory”.  
2. In your opinion what are some of the threats of not protecting ICT tools.  

 
ICT Tools security threats and measures 
ICT tools like any other tools, need protection because they can be exposed to a number of 
risks such as theft, virus, vandalism and others.  However, care must be taken in terms of 
handling, when they are in use and after use to protect them and make them less expensive 
to maintain. Physical security, Electronic security and Document/files and network security 
are very critical in addressing the measures of protecting and caring for ICT tools. Some 
examples of these security measures include burglar proofing for physical security, use of 
passwords for electronic security and use of firewalls for network security. 
 
Activity 1.8: ICT tools security threats and measures 
 
i) Take a walk around the school computer installations and identify some security and 

safety concerns. 
ii) Assuming your school has just acquired new computers and these computers need 

protection in order to be used for a long period of time. In groups, discuss security and 
safety measures to safe guard these computers in line with Physical security, electronic 
security and Document/files and network security. 

User Manuals 
The teacher will give you a sample user manual. In groups, study and discuss its features. 
 
A user guide or user's guide, also commonly known as a manual, is a technical 
communication document intended to give assistance to people using a particular system.  
 
A User guide shown in figure 1.8 contains instructions on installing, using, or troubleshooting 
a hardware or software product. 
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Figure 1.8: Example of a user guide 

 
Activity 1.9: ICT user manuals 
Using a user manual from any new ICT device or one provided by the teacher:  

a) identify the ICT for which the user manual is made. 
b) summarize contents of the user manual in a) above including the safety precautions 

therein. 

Activity of Integration 
ICTs are currently being employed in almost all fields in this modern era. Some of these 
fields are Education, Banking and Security. In the area of education, it is possible for a 
teacher in London to virtually conduct a lesson in a school in Uganda.  
 
Tasks 

a) Explain how the lesson above can be conducted by the teacher with ICTs. 
b) Explain the precautions that should be exercised when using the ICT tools in (a) 

above. 
 

Chapter Summary 
In this chapter, you have learnt about: 

 The meaning of ICT  
 Common ICTs at workplaces and their uses 
 Application of ICTs in our daily lives 
 Handling and maintaining of ICT tools 
 ICT safety precautions and Security threats  
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Chapter 2:  
Computer Hardware and System Start up 

 
Key Words 
 hardware 
 device  
 booting 
 peripheral 

By the end of this chapter you should be able to: 
a) know the physical devices of a computer system and how each operates.  
b) assemble a computer system.  
c) safely start and shut down a computer system.  
d) use computer peripheral tools.  

 
 
 

Introduction 
In this chapter you will learn about the physical parts of the computer and their use in 
everyday life.  Different parts of a computer are assembled to make a complete system. 
These parts may be manufactured by the same company or different companies. Some of 
the hardware parts are internal components (within the system case) while others are 
peripherals (externally connected to the system case through a port). As a computer user, 
you should know how to assemble the hardware parts and safely start the computer. 

Meaning of Computer Hardware 
Have you ever used a desktop computer? You realise that there is not any single part called a 
computer. Generally, a computer is a system of many parts working together as shown in figure 
2.1. 
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Figure 2.1: Computer Hardware 

 
The tangible parts that you can touch and feel, such as the monitor, keyboard, mouse, disk 
drives, printer, scanner and speakers, are collectively referred to as hardware. The opposite of 
hardware is software, which refers to the instructions or programs that tell the hardware what 
to do. Software is intangible. 
 
Note: In comparison with the human being, hardware may be considered as the body while 
software is the brain. 
 
Imagine you have been asked to type and produce a letter inviting your head teacher to a 
debating competition in your class on Tuesday at 2:00pm in the main hall. In this case, you 
can use a keyboard for typing, a mouse for controlling the cursor on the screen (these are 
input devices), the printer will be used to produce a hard copy of the work seen on the screen 
(output). Storage is done within the system unit where a hard disk is the one responsible for 
this activity.  
 
Activity 2.1: Parts of a computer 

1. Discuss and identify whether use of each of the devices labelled in figure 2.1 is an input, 
output, storage, communication or processing device and summarize your findings in the 
table below: 

Table 2.1: Parts of a desktop computer  
Label Name of device Category 
1 Mouse Input  
2   
3   
4   
5   
6   
 
Categories of Computer Hardware 
Hardware devices are categorized according to their functions. The various hardware 
categories include input, output, storage, communication and processing devices.  
Input devices are used for entering data or information into the computer after which other 
processes can follow. Output hardware is used for producing or displaying information 
which can be in form of a soft copy or hard copy. Storage devices are used for storing data or 
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information for future use. The storage devices can be inside the computer itself (internal) or 
can be external to the computer. Sometimes storage devices can be looked at in terms of the 
methods used to store data on them. For example, can you compare a flash disk and a CD? 
The method of storing data on each of these devices is different.  
 
Activity 2.2: Categories of computer hardware 
 
1. What is the difference between a soft copy and a hard copy? Give examples to 

support you answer.  
2. Move around the computer laboratory or any office in your school and identify 

other computer hardware devices other than those mentioned in figure 2.1. 
Summarize their details in terms of name, features, function and category.  

3. Identify at least one device in each category and demonstrate how it works.  
 

Assembling a Computer System 
At the beginning of this chapter, you looked at hardware devices which can be 
categorized as input devices like mouse, keyboard, microphone, camera; output 
devices like monitor, printer, projector, speakers; storage devices like hard disks, 
flash disks compact disks; processing devices like a CPU. Some of these devices are 
summarized in figure 2.2. 

 
Figure 2.2: Some examples of computer hardware 

 
When these devices are connected together, they make a computer system. For a 
computer system to work well, the above hardware devices must be connected 
properly. For instance, a keyboard, mouse, monitor should be connected to the 
System unit; the system unit and monitor then connected to power either directly to 
the sockets or through a UPS by use of power cables. 
 
If you are setting up a newly purchased computer, you will probably find a how-to 
guide or a user guide in the packaging that includes step-by-step details. However, 
even if it does not include instructions, you can still set up the computer in just a few 
easy steps. 
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Activity 2.3: Assembling a Computer System (Desktop) 
1. With guidance from your teacher, assemble a computer system from its various parts 

provided in the computer laboratory. You can make reference to the guidelines 
below. 
i) Check whether all the devices required are available. 
ii) Locate the monitor cable. It will usually be either a VGA or DVI cable. VGA cables 

will often have blue connectors to make them easier to identify.  
iii) Connect one end of the cable to the monitor port on the back of the computer 

case and the other end to the monitor. Hand-tighten the plastic-covered screws 
on the monitor cable to secure it. 

iv) Connect other devices by critically looking at the port types. 
v) Locate the power supply cables. Plug the first power supply cable into the back 

of the computer case, and then into a surge protector. Then, using the other 
cable, connect the monitor to the surge protector. 

vi) Finally, plug the surge protector into a wall outlet. You may also need to turn the 
surge protector on if it has a power switch. 

 
Note: If you don't have a surge protector, you can plug the computer directly into the 
wall. However, this is not recommended, as electrical surges can damage your 
computer. 
 

2. Explain any key steps followed to assemble a computer system in 1. above. 
3. What precautions must be taken while assembling a computer system? 

Setting up a laptop computer 
If you have a laptop, setup should be very easy. Just open it up and press the power button. If the 
battery is not charged, you will need to plug in the AC adapter and charge it before using it. 
If your laptop has any peripherals, such as external speakers, you may want to read the 
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Starting the computer: 
 Make sure all the plugs are well connected. 
 Switch on the electricity socket and the Uninterruptible Power Supply Unit. 
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 Press the power button on the computer monitor first. It should show signal. 
 Press the power button on the system unit.  
 The computer should now start to boot and load windows. 
 If the welcome screen appears, select your username and enter the password. 
 The Desktop should now appear.  
 Give it time to load the elements and start up programs. 

 

Shutting down a Computer System 
Turn off Computer option is located on the Start menu as shown in figure 2.4. The Turn off 
Computer dialog has the Turn off the computer, Standby / Hibernate, and Restart Options. 
Log Off and Switch User options are also located on the Start menu. 

 
Figue 2.4: Start menu 

Activity 2.4: Starting and shutting down a computer system  
1. Explain the logical order of switching on the assembled computer system and 

how it can be shut down properly. 
2. Stating from a fully connected computer system, demonstrate how a computer 

can be switched on and later switched off after use. 
3. What precautions MUST be considered in 2. above. 
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Activity of Integration 
Sazamwe Secondary School is planning to have a careers day to sensitise S.1 
students about the importance of vocational subjects. The 100 students of S.1 will 
assemble in the main hall which has a power supply. The career’s teacher will share 
pictures and videos showing areas where various subjects are applicable.  
 
Task 
Advise the career’s teacher on which computer hardware devices will be needed and 
how they work to support her presentation to the students. 
    
 
Chapter Summary 
In this chapter, you have learnt about: 

a) the physical devices of a computer system and how each operates.  
b) how to assemble a computer system.  
c) safely starting and shutting down a computer system.  
d) using computer peripheral tools.  
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Chapter 3 
ICT File and Folder Management 

 

 
 
 
 
 
 
Introduction  
 
Hard disk drives have become very large in recent years and are capable of holding millions 
of data files created by computer applications installed on the computer. As a result, a 
method of organising these files is essential. Windows uses folders to achieve this. 
File management is about arranging your work on a computer in a way that makes is easy to 
use and accessible. While working with your computer programs, you create and save files, 
such as letters, drawings, or budgets in an organized way. You use folders to group related 
files, as with paper folders in a file cabinet.  
In this chapter you will learn how to use different types of storage media to store information 
following the structure of files, folders and directories. 

 
 
 

By the end of this chapter, you should be able to: 
a) use the different types of storage media to create, save and 

transfer files. 

b) convert data storage into various units. 

Key Words 
 file 
 folder 
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File and Folders 

Files can be stored in folders. Folders can be stored within other folders and these are 
referred to as sub folders. Examples of the appearances of a file and a folder in windows 
Operating System is shown below. 
 
 
 
 
 
 

A Folder A File 
 
Filenames are made up of two parts; document name and file extension. 
The document name can be up to 256 characters long, including spaces while the file 
extension is determined by the application being used. 
Some examples of file extensions are shown in the table below.

 
 
 
 
 
 
 

 
Files and folders can be stored on various storage media such as Flash discs and Hard discs. 
 
Activity 3.1: File extensions and storage media 
 

1. Other than hard discs and flash discs, identify other three different storage media 
within your school computer lab. 

2. Compare any two storage media in terms of their advantages and disadvantages.  
3. What are the file extensions of files created with: 

- Microsoft Office Access 
- Microsoft Office Publisher 

 
 

Application File extension 

Microsoft Word .doc / .docx 

Microsoft PowerPoint .ppt / .pptx 
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Organising Files 
 
The management of computer files and paper files has much in common. If all the paper 

documents accrued in a house or business were stored in a single drawer without using 

paper folders, it would soon become impossible to find anything. 

 
A well organised house will have some filing system to segregate electric bills from 

telephone bills and from bank statements etc. Files on a computer should be managed in a 

similar fashion. 

 
A good practice is to use a Personal Folder to organise your files. This is the equivalent of a 

filing cabinet in paper filing. It can be created in the My Documents folder or in the C: Drive 

of the computer. This folder is the Root Folder of the filing system. Subfolders can then be 

created for subject areas. Within these, further subfolders can be used to organise the files 

within each subject. An example is shown below: 

• Create a Root folder in My Documents  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• Create Subfolders within the root folder for subject areas etc.  
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• Create further subfolders within the subject area folders 
 
 
 
 
 
 
 
 
 
 
 
 

• Continue the process until the required level of organisation achieved.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This organisation will make files easier to find and backing up your files will involve copying 

the root folder to the backup device. 

 
Activity 3.2: Creating folders 
 
Folders can be created by a number of methods: 
 
Method 1: 

1. Browse to where you want to create the folder. 
2. Click the File menu, choose New and then Folder.  

 
 
 
 
 
 
 
 
 
 
 

3. The folder is created. 
4. Type a name for the folder and press Return or click away from the folder to 

complete.    
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Method 2: 
 

1. Browse to where you want to create the folder. 

2. Right-click within the window, choose New and then Folder.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Complete as for method 1. 
 
Method 3: 
A folder can be created while saving a file in a computer application. 
 
1. In Word 2007, click the Office button and choose Save As and Word Document  
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2.  Browse to the required folder and click the Create New Folder button. 
 
 
 
 
 
 
 
 
 

3. Name the folder and Double-click it to open it. Save the file in the new folder. 
 

Managing Files and Folders 
 
Files and folders can be Selected, Copied, Pasted, Moved, Renamed and Deleted. 
 
 
Activity 3.3: Selecting Files 

1. Open a drive or go to desktop where there are files and folders. 
2. To select a single file, just click it. It changes colour on selection.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3. To select consecutive files, click the first file, hold down the Shift key and select the 

last file. The files in between are automatically selected. 
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4. To select non-consecutive files, hold down the Alt key and select the files in turn. 
 

 
 

 
 
 
 

 
 
 

 
 
 
 
5. To select all the files in a folder, click the Edit command and choose Select All. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Note:  The above procedures apply equally to groups of folders. 

 
 
Activity 3.4: Copying and pasting files 
 

1. First select the required file/s.  
2. Then right-click the files and choose Copy. 
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Note: The files are copied to an area of the memory called Clipboard. 
 

3. Browse to the destination folder, right-click it and choose Paste.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Moving Files without Leaving a Copy 
 
The procedure is similar to copy and paste except that instead of choosing Copy, you choose 
Cut.  
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Renaming Files 
 
Files must be renamed individually. To rename a file, right-click it and choose Rename. Type 
the new name and press Return or click away from the file.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Deleting Files 

Select the files to be deleted. Right-click any selected file and choose delete from the menu. 
Click the Yes button in the dialog box. 
 
 
 
 
 
 
 
 
 
 
 
 
The Recycle Bin 
Files and folders deleted from the computer are placed in the recycle bin. They are not lost 
until the recycle bin is emptied. 
 

Activity 3.5: Managing the Recycle Bin 

1. Delete a folder normally by right-clicking the folder and selecting Delete.  
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2. Check in the Recycle Bin to confirm if the folder/file has arrived.   
 
 
 
 
 
 
 
 

3. To Undelete the folder, right-click the recycle bin and choose Open.  
 
 
 
 
 
 
 
 
 
 
 
 
 

4. From the Edit menu, choose Undo Delete to restore the folder to its original location as it 
gets out of the recycle bin.  

 
 
 
 
 
 
 
 
Measurement of Storage Capacity 
In a computer system, data is represented using the binary system; combinations of binary 
digits (bits). There are only two binary digits, 1 and 0. These digits can be arranged in such a 
way that they represent characters, digits and other values. 
Data storage has various units including bits (b), Bytes (B), Kilobytes (KB), Megabytes (MB), 
Gigabytes (GB), and Terabytes (TB). 
 
Activity 3.6: Data storage units 

1. Distinguish between a bit and a byte. 
2. What is the relationship between bits, bytes, kilobytes, megabytes, gigabytes and 

terabytes? Give examples where necessary. 
 
Activity of Integration 

1. A researcher saved her draft work on a CD ROM from a friend’s computer with an 
intention of sending it to her supervisor by e-mail once she got home. However, on 
reaching home, she realized that her computer could not read a CD ROM.  
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Task: How can you advise this researcher to have her work sent to the supervisor without 
physically going back to her friend? 
 

2. A student borrowed a computer with a hard disk of 40GB on which he saved his project 
work for 3 years. The project work on the hard disk is stored on a space of 30GB. 
Recently, the owner of the computer requested to have it back and provided the student 
with a pack of 100 CDs each with a storage capacity of 700MB on which project data can 
be transferred.  
 

Task 
a) Describe how the project data could be transferred from the hard disk onto the CDs 

provided by the student. 
b) How many CDs full of data do you think the student used? Give reasons for you answer. 

 

Chapter Summary 
In this chapter, you have learnt about: 

 creating, saving and transferring files across various media. 
 converting data storage into various units. 
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Chapter 4 
Word Processing I 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

By the end of this chapter you should be able to: 
a) understand the word process or interface. 

b) use a word processing software to create, format, edit and print a 
document. 

Key Words 
 word processing 
 layout 
 mail merge 

Introduction 
Word processing is a very important skill for you if you are aiming at becoming 
computer literate. Once you have learnt how to word process, you will be in position 
to use word processing software (e.g. MS Word) appropriately to create, edit and 
print documents. 
 
There are specialized programs which you can use to word process. Such programs 
are called word processors. A word processor has numerous features whose uses 
you need to understand if you are to use it appropriately.   
 
Microsoft Office Word is one of the most commonly used word processing software. 
Different versions of Microsoft Office Word include MS Word 2007, 2010, 2013 and 
2016. In this book we are going to demonstrate using Microsoft Office Word 2007 
Platform. 
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Features of a Word Processor 
 
 
 
 
 
 
 
 
 
 
 
 

                                       Figure 4.1: MS Word processor window 
 
Activity 4.1: Understanding the features of a word processor 
In groups: 

1. open a word processor.  
2. identify the groups of the word processing features. 
3. type the sentence “I love my school”. 
4. select (highlight) the sentence in 3 above and click on any three features.  
5. observe the changes which occur in the text.  
6. state the function of each of the features identified.  
 

Copy and complete the table shown below about the features of a word processor 
Feature Identified Group it belongs to Use of the feature in word 

processing 

   

   

   

 
7. Share your findings on the word processing features and the group they belong to.  

Hint: To open a Word Processor, go to Start →All Programs → MS Office → Word Processing program 
 

Customizing Word Processing Working Environment 
 
Before you begin creating documents, ensure that you have set up your Word 
environment and become familiar with a few key tasks such as minimizing and maximizing 
the ribbon, configuring the Quick Access toolbar, using the ruler, word counting and zooming 
tools.  
 

The image on the right shows a 
window of a word processor 
with some features that enable 
a user to manipulate a 
document.  
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Activity 4.2: Setting a word processing environment 
 
Customizing the Quick Access Toolbar  

1. Click the arrow to the right of the 
Quick Access toolbar. 

2. Select the command you want to add 
from the drop-down list. It will appear 
in the Quick Access toolbar. 

Minimising and Maximising the Ribbon 

3. Right-click anywhere in the main menu. 

4. Select Minimize the Ribbon in the 
menu that appears. This will toggle the 
Ribbon on and off. 

 
 
Customising the task bar 
5. Right-click anywhere on the task bar. 

6. Select the items you would like to appear on 
your task bar as you work from the popup 
menu.  

 
 
 
 
 
 
Saving an MS Word Document File 
Saving is the process of storing a document in a certain location or creating a file. This can be 
done on a newly created document or on an already existing document. Saving is normally in 
two categories; Save and Save As. 
 
When saving for the very first time, Save and Save As behave the same way. They both prompt 
for file name and location. 

Click on the Office button>Save As>Type File Name>Choose Location>Save 
Otherwise, Save and Save As behave differently on an existing document. 
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Save 
This is a command used when saving changes made on an existing document without changing 
the file name and location.  
 
Save As 
This is a command used when making a copy of the file in a different folder or making a copy 
with a different name.  
Click on the Office button>Save As>Type File Name>Choose Location>Save 
 
Activity 4.3: Saving a file 
Saving a document with file name NCDC in My Documents location: 

1. Open MS Word program. 
2. Select Office Button > Save or Save As. 
3. Select Desktop as the location to save in. 
4. Give the file a name, NCDC. 

 
Tip: Save your file immediately after creating it to prevent the possibility of losing it later due to 
power failure. 
 
Activity 4.4: Working with text 
1. Type some text in your text area of about four paragraphs to help you practise word 

processing skills. Press Enter key on your keyboard to get to the next line. 
 
Selecting text 
2. Move your insertion point next to the text you want to select. 
3. Left-click and while holding down, drag the mouse over the text you want to select. 
4. Release the mouse button. You will have selected the text.  A highlighted box will appear 

over the selected text. 
 
Inserting text anywhere in your text 
5. Move your mouse to the location where you want text to appear in the document. 
6. Left-click the mouse. The insertion point appears. 
7. Type the text you want to appear. 
 
Deleting text 
8. Place your cursor next to the text you want to delete. 

9. Press the Backspace key on your keyboard to delete text to the left of the cursor. 

10. Press the Delete key on your keyboard to delete text to the right of the cursor. 

 
Copying and Pasting Text 
11. Select the text you want to copy. 

12. Click the Copy command on the Home tab. 
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13. Place the cursor where you want text to appear. 

14. Click the Paste command on the Home tab.  

 
Tip: Highlight text before applying any formatting on it.  

 
Page Layout  
All along you have been using the default settings of your word processor. You are now going to 
learn how to change these settings to suit your document requirements. In the next set of 
activities you will learn how to change the margins, document orientation, use columns in your 
document as well as adjust the line spacing of text.  
 
Activity 4.5: Changing page orientation 
 
Open a page with text on it. 

1. Select the Page Layout tab. 

2. Click the Orientation command 
in the Page Setup group. 

3. Left-click either Portrait or 
Landscape to change the page 
orientation. 
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Activity 4.6: Setting the margins 
The margins of the document determine the amount of text area 
for your document. To change your margins: 

1. Select the Page Layout tab. 

2. Click the Margins command. A menu of options 
appears. Normal is selected by default. 

3. Left-click the predefined margin size you want. 
 
 
 
 
 
 
 
 

 
 
You can also change the page margins by clicking on the custom 
margins from the menu. The page set up dialogue box appears 
from which you use the arrows or directly type in the desired 
margin sizes. 
 
 
 
 
 
 
 
 

 
 
Using Columns 
Most newspapers, magazines, academic journals, 
newsletters’ texts are laid out in columns. In the default 
settings your word processor has one column.  
 
Activity 4.7: Using columns in text 
You can change the number of columns by following 
these steps: 

1. Create a paragraph of text or Copy and paste 
some text onto your page. 

2. Select the text you want to format. 
3. Select the Page Layout tab. 
4. Left-click the Columns command. 
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5. Select the number of columns you want to insert. 
 

Note: More columns can be got by selecting the more Columns menu.  
 
Navigating through a Document  
Navigation means moving around a document. This can be done using arrow keys shown below 
or Keyboard shortcuts. 
 

 
 
 
Activity 4.8: Using arrow keys 

1. Open a word document with text. 
2. Press the arrow keys on your keyboard and observe how the cursor moves around the 

screen. You can also click your mouse within the document to place the insertion point 
where you want to type next. 

 
Locating Specific text in a word document 
When a document comprises many pages, locating a specific text might be cumbersome. Word 
processors have a mechanism of locating specific texts. 
 
Activity 4.9: Locating specific text 

1. Load a file with text on at least two pages. 
2. Click the Home ribbon’s Find button to display the Find and Replace dialog box OR 

Press Ctrl+F to display the Find and Replace dialog box. 
3. Enter Search Text 
4. Type the text you want to find in the Search for text box. 
5. Start the Search 
6. Click the Find Next button.  

 
Note: Word searches from the current text cursor’s position in the document to the end of the 
file. If Word finds the text, it highlights it. 
 
Activity 4.10: Replacing Text 

1. Select the text you want to replace. 
2. Click the Home ribbon’s Replace button instead of the Find button to display the Find 

and Replace dialog box.  OR Press Ctrl+H to display the Find and Replace dialog box.  
3. Type the new text into the “Replace with” text box. 
4. Replace the Text. 
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3. Enter Search Text 
4. Type the text you want to find in the Search for text box. 
5. Start the Search 
6. Click the Find Next button.  

 
Note: Word searches from the current text cursor’s position in the document to the end of the 
file. If Word finds the text, it highlights it. 
 
Activity 4.10: Replacing Text 

1. Select the text you want to replace. 
2. Click the Home ribbon’s Replace button instead of the Find button to display the Find 

and Replace dialog box.  OR Press Ctrl+H to display the Find and Replace dialog box.  
3. Type the new text into the “Replace with” text box. 
4. Replace the Text. 
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5. Click the Replace button to replace the next occurrence of the found text with your 
replacement text.  

 
Grammar and spell check 
When you are typing, sometimes a wavy red or green line appears beneath your text. Red and 
Green wavy lines indicate spelling and grammatical errors respectively. Missing space after a 
comma or a period, or doubling of a word (the the), is also detected as a mistake. Below is an 
example of a spell checker in action. 

 
 
Activity 4.11: Text proofreading 

1. Open a new document. 

2. Mistype a word so that the wavy red line appears. For instance tyiping. 
3. Right click on the underlined word. A context-sensitive menu will open up.  

 
 

4. Click on the correct suggestion, the mistyped word will automatically be replaced.  

In case Word does not make any suggestions, then check whether maybe you left out a space 
after a period or comma. Please note that there are many proper nouns and specialist terms 
that Word does not recognize.  
 
Tip: A wavy red line does not always mean that you have made a mistake!  
 
Character formatting 
Formatting is the art of making your documents effective and attractive. Good formatting 
distinguishes different parts of your text and helps your readers take in your message. Word 
processors provide a wide range of tools that can help you create professional looking 
documents. Characteristics that affect the appearance of one or more characters are called 
character formats. You can apply formatting to just about every element of your document, 
from a single character to entire paragraphs. The formatting ribbon below contains functions 
which can format characters, sections, and paragraphs. 
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Changing the font 
 
Use the Font dialog box (Alt+H, FN) to format characters. Letters, numbers, and punctuation 
marks are all printable characters and, as such, you can format them. Once you select a 
character or a group of characters, you can apply any of the formatting commands on the Home 
tab’s Font group (Alt+H). You can choose a font and a size for any character in your document. 
You can make characters bold, underlined, superscript, or change them to just about any colour 
of the rainbow. 
 
Activity 4.12: Character formatting 
 

1. Select the text you want to format. 
2. Find the Font field on the Home ribbon. 

  
3. Click the drop-down arrow next to the Font field. 
4. A list with countless font choices appears as shown below. 

 
 

5. Select the font you want by clicking its name. You can also change the font 
size to your preference. 

 
6. First select the relevant text. 
7. Find the Font Size field on the Home ribbon, and click the drop-down arrow 

next to it. 
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8. On the list, find the font size that suits you and click it. 

You can also format your text to be bold, italic or underlined.   
Tip: You can also specify your own font size by clicking in the Font Size field and typing in the 
size that you want and then press ENTER.  

  
Activity 4.13: Bolding, italicizing and underlining 
\ 

1. Select the relevant portion of your text. 
2. Click the appropriate character formatting button on the Home ribbon. 

  - Bold 

  - Italic 

  - Underline  
3. The drop down arrow next to the underline button offers you a choice of underlining 

styles. 
4. To turn a character format off, select the text and click the same button again. 

 
Alignment of Text 

By default, paragraphs are usually left-aligned: the left margin is straight, but the right 
margin is jagged. Word provides you with a number of other options though. Just 

position your cursor anywhere in the paragraph, and       

click on one of the text alignment buttons on the Home ribbon. 
 

    Align left: text is aligned at the left margin but jagged on the right. 

 Centre: text is centred within each line, with jagged margins on both left and 

right.  

    Align right: Text is aligned at the right margin but jagged on the left. 
    Justify: text is aligned at both the left and right margins (Word does this by 

adjusting the amount of space between words). 
 
How to Create a Bulleted and Number List  
Using bullets 

• First, type the points that you want to bullet, one under another. Make sure you 
create them as individual paragraphs by pressing [ENTER] after typing each 
point. 

• Select the paragraphs that you would like to bullet. 

•  Click the Bullets button in the Paragraph section of the Home ribbon.                 
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Tip: The drop-down arrow on the right of the Bullets button allows you to choose 
 from different bullet styles. 

 
Creating a Numbered List 

Instead of clicking the Bullets button, click the Numbering button just next to it.  
The best thing about Word numbering is that the numbers adjust themselves 
automatically when you edit the text. 
 

Tip: To end a bulleted or numbered list, just press [ENTER] twice. 
 

Changing the Bullet/Number Style 
Go to the drop down list bullet or number (figure below) and select an option. 
 
Note: Adding a Numbered List follows similar steps 

 
 

Adjusting Line spacing 

When words are close together or sentences are compact, they can be difficult to read 
for some people. Depending on the font type used, it may not look nice to read. 
Therefore, word processors have line spacing provision 
to allow space adjustments between the lines. 

Activity 4.14: Working with line spacing 

1. Select the text you want to format. 

2. Click the Line spacing command in the 
Paragraph group on the Home tab. 

3. Select a spacing option. 
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If you select Line Spacing Options, the Paragraph dialog box appears. 

 
4. Use the Line spacing drop-down menu to 

select a spacing option. 

5. Modify the before and after points to 
adjust line spacing as needed. 

6. Click OK. 

 

 

Working with Objects 

In the previous activities, you have been working 
with text only. In this section, you will add 
information to your text in form of objects. You 
will learn how to add images/pictures, tables, charts smart arts, screenshots and 
illustrations.  

Making use of Clip Art Objects 

You might be asking yourself “what is clip art?”  Clip art is a collection of pictures or 
images that can be imported into a document or another program. They are already 
part of your word processing software.  
 
Activity 4.15: Working with Clip Art 

1. Select the Insert tab. 

2. Click the Clip Art command in 
the Illustrations group. 

3. The Clip Art options appear in the task 
pane on the right. 

4. Enter keywords in the Search for field that 
are related to the image you want to 
insert. 

5. Click the drop-down arrow next to 
the Search in field. 

6. Select Everywhere to ensure Word searches your computer and its online 
resources for an image that meets your criteria. 

7. Click the drop-down arrow in the Results should be field. 

8. Deselect any media types you do not want to see. In this case we only wanted 
Clip Arts. 
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9. Click Go to see a list of images depending on 
your search. 

10. Try to insert other object types (tables, pictures, 
charts, header/footer). 

 

Formatting Images/Pictures 

Most times, images inserted may need some 
adjustments to fit properly into spaces where they are 
inserted. This can be done in various ways including 
cropping and compressing the images. When you crop 
an image, part of it is removed. Cropping may be helpful 
when a picture has a lot of content and you want to focus on only part of it. 

 

Activity 4.16: Cropping images 

1. Select the image you want to crop. The Format tab appears. 

 
2. On the Format tab, click the Crop command. 

3. Cropping handles will appear around the image. Click, hold, and drag 
a handle to crop the image. 

4. Click the Crop command to deselect the crop tool. 

Note: The mouse pointer appearance may vary from MS Word version to version. 
 
Compressing Images 

If you use large pictures in a document, its file size increases rapidly. As a result it may be 
difficult to share such a file via the Internet. You can reduce this problem by telling a word 
processor to compress the pictures inserted in a document. 
 
Activity 4.17: Compressing images 

1. Select the picture. 

2. Select the Format tab. 
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3. Click the Compress Pictures command in the Adjust group; a dialog box 

appears. 

4. Click the Options button to access the Compression Setting dialog box. 

5. Choose the target output. 

6. Change any of the default picture settings you want. 

7. Click OK in the Compression Settings dialog box. 

8. Click OK in the Compress Pictures dialog box. 

 

Activity 4.18: Comparison of compressing and cropping 

In groups, distinguish between cropping and compression in relation to images in a 
document. 
 
Working with Tables in a Document 
A table is made up of rows and columns. Tables are mainly used to organize and present 
information. You can also use tables to align numbers and create interesting page layouts.  

 
 
Activity 4.19: Inserting a table 

1. Click where you want to insert the table. 

2.  Click the Insert tab and click on the [Table] button - a table grid and other options 
appear: 
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3.   Create a 3 x 3 Table. Drag the mouse cursor over the cells and click the mouse button 

when the table is of the desired size (if you hold down the mouse button, the table is 
drawn when you release it). 

 
Tip: You do not have to set up the number of rows required when you first create a  
 table as Word will automatically add extra rows for you as you type. 
4.   To move out of the table, press <Ctrl End> or use the <down arrow> key several times 

– the Table Tools tabs disappear, showing that you are no longer in the table. 
5.   Press <Enter> for a blank line. 

 
 
Inserting a Table by Setting the Number of Rows and Columns 
 

1.   Position the Insertion Point where the table is required. 

2.   Click on the [Table] button (on the Insert tab) and choose Insert Table… command. 

3.   The Insert Table dialog box appears - under Table size, enter the Number of columns: and 
Number of rows: required (here, set up 4  columns and   2 rows). 
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The next set of options down, AutoFit behaviour, determine how the column widths are 
defined. By default, column widths are set so that the table fills the page horizontally with 
equally-sized columns (as you saw with the first table). If you require specific widths (of an 
equal size) change Fixed column width: from Auto to the desired size.  

4.   Here, change AutoFit behaviour to AutoFit to contents. 

5.   Press <Enter> or [OK] and a very small skeleton table appears. 
 
 
Activity of Integration: Word Processing a Letter 
 
Your class is planning an end of year party scheduled fo 21st November this year. It will take 
place in the main hall starting at 8:30 am.  
 
Task: Word process a letter inviting the head teacher and members of staff to the party. 
 

 

Chapter Summary 
In this chapter, you have learnt about: 

 how to load word processing application software. 
 format a Word document (page orientation, margins, size, fonts, paragraphing, etc.). 
 insert objects in a Word document (tables, images, shapes, header and footer). 
 print documents. 
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